Back to overview
Degraded
Temporary Network Outage Affecting Macrocosm
Feb 10 at 02:18pm PST
Affected services
Macrocosm
Resolved
Feb 10 at 03:04pm PST
The issue has been resolved.
Affected services
Created
Feb 10 at 02:18pm PST
Temporary network outage affects part of the Macrocosm service.
Affected services