Back to overview
Degraded
Some services are down
May 13, 2026 at 7:10pm UTC
Affected services
Macrocosm
Resolved
May 13, 2026 at 9:07pm UTC
Macrocosm has fully recovered and the incident has been resolved.
Affected services
Created
May 13, 2026 at 7:10pm UTC
Part of Macrocosm went down due to a power outage in our server area.
Affected services