Resolved
This issue has been resolved. All affected services are operating normally.
Monitoring
Service has been restored for Mac nodes and iMessage. We are monitoring the recovery of our systems following the upstream power-provider outage affecting our data center.
Identified
Customers are unable to use services that rely on our Mac nodes and iMessage.
An outage affecting our upstream power provider is impacting critical infrastructure at our data center. We are working to restore service and will share an estimated restoration time when it is available.
Identified
Some customers are unable to use services that rely on our Mac nodes and iMessage.
A power outage at our data center is affecting critical infrastructure. We are working to restore service.
Identified
Some customers may be unable to use services that rely on our Mac nodes and iMessage.
We have identified a power outage at our data center affecting critical infrastructure and are working to restore service.